
 i 

Contents 

1. Software Installation.................................................................................................................................... 1 

1.1 Download .......................................................................................................................................... 1 

1.2 Installation & Start ............................................................................................................................. 1 

2. Software Operating Instructions ................................................................................................................. 1 

2.1 Load File ............................................................................................................................................ 2 

2.2 Mouse Operations ............................................................................................................................. 3 

2.2.1 Left click .................................................................................................................................. 3 

2.2.2 Left click and hold the left button .......................................................................................... 3 

2.2.3 Right click and hold the right button ...................................................................................... 3 

2.2.4 Scroll the mouse wheel .......................................................................................................... 3 

2.3 Change Views .................................................................................................................................... 3 

2.3.1 Move ....................................................................................................................................... 3 

2.3.2 Rotate ..................................................................................................................................... 3 

2.3.3 Scale ........................................................................................................................................ 3 

2.3.4 Set ........................................................................................................................................... 3 

2.3.5 Reset ....................................................................................................................................... 4 

2.3.6 Show Model Outline ............................................................................................................... 4 

2.3.7 Show Steep Overhang ............................................................................................................ 4 

2.4 Edit Models ........................................................................................................................................ 4 

2.4.1 Move ....................................................................................................................................... 4 

2.4.2 Rotate ..................................................................................................................................... 4 

2.4.3 Scale ........................................................................................................................................ 4 

2.4.4 Set ........................................................................................................................................... 5 

2.4.5 Others ..................................................................................................................................... 5 

2.5 Edit Supports ..................................................................................................................................... 6 

2.5.1 Auto Supports ......................................................................................................................... 6 

2.5.2 Clear Supports ........................................................................................................................ 7 

2.5.3 Add ......................................................................................................................................... 7 

2.5.4 Delete ..................................................................................................................................... 7 

2.6 New Project ....................................................................................................................................... 7 

2.7 Saving File .......................................................................................................................................... 7 

2.8 Printing Process ................................................................................................................................. 8 

2.8.1 Choose Machine Type ............................................................................................................ 8 

2.8.2 Connect Machine ................................................................................................................... 8 

2.8.3 Print ........................................................................................................................................ 8 

2.9 Printer Operations ........................................................................................................................... 12 

2.9.1 Connect / Disconnect ........................................................................................................... 12 

2.9.2 Control Panel ........................................................................................................................ 15 

2.9.3 Firmware Upgrade ................................................................................................................ 17 

2.9.4 On Board Preferences ........................................................................................................... 18 

2.9.5 Machine Information ............................................................................................................ 18 

2.9.6 Driver Installation ................................................................................................................. 18 



 ii 

2.10 Others ............................................................................................................................................ 18 

2.10.1 Preferences ......................................................................................................................... 18 

2.10.2 Help Contents ..................................................................................................................... 19 

2.10.3 Check for Updates .............................................................................................................. 19 

2.10.4 Software Information ......................................................................................................... 19 

 



 1 

Help Contents for Dreamer Series 

1. Software Installation 

1.1 Download 

A. Insert SD card sent with Dreamer into a computer, we have already prepare the latest driver  

  installation package in the SD card. 

B. Open below link to download the installation package:    

   http://www.ff3dp.com/#!sup/c1df1                                                                                                      

1.2 Installation & Start 

    A. Uncompress the downloaded RAR, and complete installation according to the instruction. 

B. Connect your Dreamer desktop 3D printer with USB cable and make sure that the printer is  

  connected to the computer successfully. Start the software with the shortcut on computer desktop 

  or in the Start Menu. 

    Note: This software supports Windows XP/Win 7 32-bit and 64 bit/ Win 8 and Mac operating system.  

2. Software Operating Instructions 

 

http://www.ff3dp.com/#!sup/c1df1
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Load into one or multiple files. 

 

 

View FlashPrint home screen from one of six viewing angles. 

 

 

Move model around on xy-plane; shift+click to move along z axis 

 

 

Turn and rotate your model 

 

 

Scale the size of your model 

 

 

Select right or left extruder you want to print with 

 

 

Print it directly with your Dreamer or export to your SD card. 

 

You can use Flashprint software to control Dreamer and perform printing tasks.  

2.1 Load File 

  You can load a model file or Gcode file into the software by following six methods:  

A. Click the “Load” button on top of the software interface. Then select the file which is  

  needed for loading. 

B. Select the file which is needed for loading, and then drag the file to the interface of the 

  software. 

C. Click the “File -> Load File” menu. Then select the file which is needed for loading. 

D. Click the “File -> Examples” menu. Then select the file which is needed for loading. 

E. Click the “File -> Recent Files” menu. Then select the file which is needed for loading. 

F. Select the file which is needed for loading, and then drag the file to the icon of the  

  software. 

You can load into .stl, .obj, or .fpp model files which are editable in the software. Please refer to Chapter 

2.2~2.5 and you can find instructions of that modification, such as operations of mouse, changes of view 

from different angles and how to edit and save the file. After modification, please refer to Chapter 2.6 if 

you want to slice the model file , generate Gcode file and Print it.   

Important Note: Gcode file can not be edited any more, but you can directly start the printing after 

loading it into the software. Please refer to the Chapter 2.6.1 and 2.6.2.2 which tells you how to connect 

to Dreamer and how to print the Gcode file. 
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2.2 Mouse Operations 

2.2.1 Left click 

A. Select a model by moving the mouse to it and just left click it. 

B. Select multiple models by holding the Ctrl key and left click models you want. 

C. Model looks brighter when selected. 

D. Model can be edited when selected. 

E. Left click blank space to undo the selection of model. 

2.2.2 Left click and hold the left button 

When changing the viewing angles or editing models, different effects appears by left-clicking and 

holding the left button. Please refer to Chapter 2.3.1~2.3.2 & 2.4.  

2.2.3 Right click and hold the right button 

Same results in any operations when right clicking and holding the right button. Please refer to the 

Chapter 2.3.1 & 2.3.2. 

2.2.4 Scroll the mouse wheel 

Same effects in any operations when scrolling the mouse wheel. Please refer to the Chapter 2.3.3. 

2.3 Change Views 

Change your view of the model by moving, rotating, scaling the view and so on. 

2.3.1 Move 

You can move the view of printing frame in the software interface by following three ways:  

A. Long-press the left button of mouse and drag. 

B. Press and hold the middle button of mouse, and then drag the mouse. 

C. Hold the Shift key, long-press the right button of mouse and drag.  

2.3.2 Rotate 

You can rotate the view of printing frame in the software interface by following two ways,  

A. Long-press the right button of mouse and drag. 

B. Hold the Shift key, long-press the left button of mouse and drag.  

  

2.3.3 Scale 

You can scale the view of printing frame in the software interface by scrolling the mouse wheel in any 

condition.  

2.3.4 Set 

You can set the view of printing frame in the software interface from six angels by following two ways 

to observe the model.(Top/Bottom/Front/Back/Left/Right View) .   

A. Click the View menu, and then select the view you need to observe the model. 

    B. Click the Look button on the left of the software interface, and select the view you need.  
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2.3.5 Reset 

A. Click the View menu, and then select Home view to reset the view. 

B. Click the Look button on the left of the software interface, and then click Reset button to reset it. 

2.3.6 Show Model Outline  

Click the View -> Show Model Outline, it will highlight the outer surfaces of your model file with gray 

and white color. 

2.3.7 Show Steep Overhang 

Click the View -> Show Steep Overhang menu. When the intersection angle between the model 

surface and horizontal line is within the overhang threshold value, we say the surface has steep 

overhang and it becomes red in the software. Overhang threshold value could be set as needed. The 

default value is 45 degree. 

2.4 Edit Models 

You can edit the models by moving, rotating, scaling the model and so on. 

2.4.1 Move 

When the model is selected, you can change model location on the build platform by the following 

two ways:   

A. Click Move button on the left of the software interface. Long-press the left button of mouse and 

drag, you could adjust the location of the model in XY direction. Hold the shift key, and long-press 

the left button of mouse and drag, you can adjust the location of the model in Z direction. You can 

see the distance and direction of the movement which refers to the relative distance between 

present and former location.  

B. Click Move button on the left of the software interface and then enter the distance value you 

want to move on X/Y/Z axes positioning. Click Reset button to reset distance values.  

Note: Generally, we suggest you to click the Center and On Platform buttons after adjusting location 

of the model to make sure the model within the printing scope and sticking to HBP. Only click On 

Platform button if you want to print the model in a specified position.  

2.4.2 Rotate  

When the model is selected, you can change the orientation of your model on the build platform by 

following two ways: 

A. Click Rotate button on the left of the software interface and you can find three mutually 

perpendicular rings whose color is red, green and blue. Click one ring and rotate on the present axis, 

you will see the rotation angle and direction in the center of circle. In this way, you could make the 

model rotate on X/Y/Z axis. 

B. Click the Rotate button on the left of the software interface, and then enter into rotating angel 

values in X/Y/Z axes positioning. Click Reset button to reset rotating angel values.  

2.4.3 Scale 

When the model is selected, you could change the size of the model on the build platform by the 

following two ways.   



 5 

A. Click Scale button on the left of the software interface, then press the left button and move the 

mouse to adjust the size of the model. You will see corresponding values of different axes near the 

borders.  

B. Click Scale button on the left of the software interface, and then enter into scale values in X/Y/Z 

axes positioning. Click Maximum button to get largest size possible for building. Click Reset button to 

reset the size of model.  

Note: Select Uniform Scaling option, it will scale the model in equal proportion when changing value 

in any positioning of the model. Not select this option, it will only change the value of the 

corresponding positioning. 

2.4.4 Set  

When the model is selected, click Extruder button on the left of the software interface and select the 

extruder you want to print with. The model will turn purple if you choose left extruder or gray if right 

extruder.  

If a model can be printed with dual extruders or the support is needed to complete the printing, you 

can use dual extruders to print it with different color filaments or even different kinds of filament. 

However, dual extrusion printing is not available when the model can only be printed with one 

extruder. You need to know whether the model diagraph has single or dual colors when selecting the 

model. Dual-color model is combined with two single color models. 

Note: When setting the extruder, mouse operations are same as those of changing views. Please refer 

to the Chapter 2.3.1~2.3.2. 

2.4.5 Others 

     2.4.5.1 Undo 

       Undo the most recent edit you made to your model file by following two ways:  

   A. Click Edit-> Undo menu. 

   B. Use the shortcut Ctrl+Z.  

   Note: Selecting this option multiple times will continue to undo edits in reverse order in  

   Which they were performed. 

     2.4.5.2 Redo 

       Redo the most recent edit you have undone to your model file by following two ways: 

   A. Click Edit-> Redo menu. 

   B. Use the shortcut Ctrl+Y.  

   Note: Selecting this option multiple times will continue to redo edits in reverse order in which    

   they were removed. 

     2.4.5.3 Select ALL 

   By the following two methods, you could select all models in the scene. 

   A. Click Edit-> Select ALL menu.   

   B. Use the shortcut Ctrl+A.  

   Note: When models are too small to be seen or out of viewing scope, please click Center and On 

   Platform buttons after selecting all models to bring them to the printing scope. 
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     2.4.5.4 Duplicate 

   After model is selected, you can duplicate it by the following two methods: 

   A. Click the Edit-> Duplicate menu.  

   B. Use the shortcut Ctrl+D. 

     2.4.5.5 Delete 

   After model is selected, you can delete it by the following two methods: 

   A. Click the Edit-> Delete menu. 

   B. Use the shortcut Del. 

2.5 Edit Supports 

After model file is loaded, click Edit->Supports in the top menu, you can edit the support structures of 

your model. Click Back on the top-right corner to exit when finishing the edits. 

 

2.5.1 Auto Supports 

Select this option to have your model build with support structures. FlashPrint software will 

automatically generate supports for any overhanging sections of your model, and it will generate 

new support structures to replace original ones included in your model file. 
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2.5.2 Clear Supports 

Select this option to empty all the supports of your model. Click Edit->Undo in the menu or Ctrl+Z to 

undo this operation. 

2.5.3 Add 

Select this option to add supports. After selecting this option, move the mouse to where you want to 

add the support, and then left-click the mouse to select the start point of support structure. Press 

and hold the left mouse button down, drag the mouse, and then you can preview the support 

structure you will add (If the support surface does not need to support or the angle of support 

column is too large, the previewed support structure will be highlighted.) Release the left button of 

mouse to add this support, the support structure will be generated according to the start and the 

end position. But if the support column intersects with the model or the previewed support structure 

is highlighted, support structure will not be generated. 

2.5.4 Delete 

Select this option to delete supports. After selecting this option, move the mouse to the supports 

you want to delete, then left-click the mouse to delete it. 

2.6 New Project  

Click File -> New Project to create a new project. If your current project hasn’t been saved with changes, it 

will pop up a dialog to prompt you to save them. Click Yes button to save those changes, click No button to 

discard them, Click Cancel button to close this dialog and it will not create a new project. 

 

 

2.7 Saving File  

You can save changes of your model files by following two ways:  

A. Click File -> Save Project to save your file only with .fpp format. All the models(including supports)  

in a .fpp format file are independent and they can be edited again when reloading the file. Besides, 

extruders’ configuration and models’ locations remain same as saving the file. 

B. Click File -> Save As to save your file with .stl, .obj, or .fpp format. All the models (including 

supports) in a .stl or .obj format file are not independent, but combined to a new model. Models’ 

locations remain same as saving the file, while extruders’ configuration becomes different when 

reloading the file. 
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2.8 Printing Process 

2.8.1 Choose Machine Type 

Click Print-> Machine Type to choose the machine type you have before connecting to the printer, or 

the FlashPrint will automatically recognize the machine type after connecting, in this case you can 

not manual switch to other machine type(s). Different machine types have different machine frames 

which will affect sliced file(s). 

 2.8.2 Connect Machine 

Please refer to Chapter 2.9.1.1 for configurations of connecting to Dreamer 3D printer. 

 2.8.3 Print  

    2.8.3.1 Generate Gcode File 

  In order to print, you need to slice the model file to generate gcode file firstly through following 

  steps: 

      1. Click Print -> Print menu or Print button on top of the software interface, it will pop up a dialog 

box for slicing.  
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    2. Set slicing parameters and click Ok button, and it will pop up a dialog box for saving Gcode file. 

3. In the Save as dialog box, select the path for saving the Gcode file, and then click Save button. You  

  can see the bar at the bottom of software interface start to show the completion progress of  

  slicing, which means it is slicing and uploading Gcode file now. Click Abort button on the right side  

  of the process bar to give up slicing. 
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   2.8.2.2 Explanation of Slicing settings 
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      A. Preview: Select this option to preview the Gcode file when slicing finished. 

      B. Print When Slice Done: Select this option to directly print the model. 

      C. Slice Engine: Three slice engines are provided: Slic3r, Skeinforge and ffslicer. Different slice  

        engines have different configurations. Recommend users to select Slic3r as it has a better  

        performance.   

      D. Material Right: Choose filament type you want to print with right extruder.  

      E. Material Left: Choose filament type you want to print with left extruder. 

      F. Supports: Choose Left or Right Extruder to print supports when overhang is existing, or  

        Disable when no need. 

      G. Raft: Choose Left or Right Extruder to print raft which can make the model attach well to the 

        build plate, or Disable when no need. (Note: Slic3r has no this function, while Skeinforge has  

        this function with default extruder to print the raft. You can choose left or right extruder to 

        print the raft when using ffslicer.) 

      H. Skirt: Select this option to help extruder extrude filament more smoothly. (Note: ffslicer has  

         no this function.) 

      I. Wall: Select this option to scrape extruded filament from a non-printing extruder during dual  

        extrusion print. (Note: Skeinforge has no this function. This function can’t be used with Skirt 

        at the same time.) 

      J. Use Editable Supports: Select this option to disable the built-in supports function in the slice  

        engine and use the support structures generated by FlashPrint software. As ffslicer has no  

        built-in support function, so this function is always enabled. 

      K. Resolution: When printing right extruder with ABS or dissolvable filament, you can select  

        High option with better print but lower speed, or Standard option, or Low option with normal  

        print but high speed. Each option has its own configured parameter. While printing right 

        extruder with PLA filament, you have the fourth option, which is Hyper with hyperfine print. 

 

     Click More Option button to set the parameters as you want. Different resolutions have different  

     default parameters. Click Restore Defaults to restore it. 

             
       A. Layers 

          a. Layer Height is the height of each layer. The lower value of layer height is, the finer  

            surface of the model will be . 

          b. First Layer Height exists when users choose Slic3r as the slice engine, and it affects 

            the adhesion degree between model and platform. The max value is 0.4mm. Normally we 
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            recommend you to use default value. 

          c. Number of Shells is the quantity of shells of each layer. The max value is 10.  

       B. Infill   

          a. Fill Density means fill rate. 

          b. Fill Pattern is the pattern of filling shape which effects printing duration. 

       C. Speed   

          a. Print Speed is the moving speed of the extruder. Generally, the lower speed is, the better  

            print you will get. For ABS printing, 60 is recommended; for PLA printing, 80 is  

            recommended. 

          b. Support Print Speed is needed to set when choosing Slic3r as the slice engine which  

            can control the moving speed of the extruder when printing the supports.  

          c. Travel Speed is to control the moving speed of the extruder under non-printing status   

            during work. For ABS printing, 80 is recommended; for PLA printing, 100 is recommended. 

       Note: Modify parameters settings to get better prints as different models need different  

       parameters. 

        D. Temp. Set the temperature for left or right extruder and platform. Set 220 to the extruder  

          temp for ABS and PLA printing. Set 110 to the platform temp for ABS printing while 50 for  

          PLA printing. Adjust the temperature according to the condition in order to get a good print. 

        E. Others  

          a. Turn Fan On is to turn on the back fans to cool the chamber if printing PLA . 

          b. Overhang Threshold helps to measure whether a support structure is needed or not. If the  

            intersection angle between model surface and horizontal line is within the overhang  

            threshold value, then this surface needs a support. 

  2.8.2.3 Print Gcode File 

 After finishing slicing, it will load into the generated Gcode file automatically if you select Preview  

 option when slicing, or need you manually load into it and then go to preview interface. In the   

 preview interface, there is a vertical scroll bar which shows each layer of the model and you can find 

 Estimated Material Right and Estimated Print Time it costs on the top right corner. Then click Print 

 button on the same location, the machine starts to print while click Back button to exit from  

 Preview mode. 

  2.8.2.4 Pause or Terminate Printing 

     Once printing starts, click the machine icon on the bottom right corner of the software interface  

     and it will show the process status in a frame. Click Pause button to pause printing and then click  

     Continue button to resume it. Click Stop button to cancel this printing task and you need to restart  

     this print task if you want to print it again.  

     Note: Please DO NOT click Pause button unless necessary, for it will affect printing result.  

2.9 Printer Operations 

2.9.1 Connect / Disconnect   

   You can connect Dreamer to Flashprint software via USB cable or WIFI. The machine icon on the  

   bottom right corner of the software interface shows a broken chain pattern means disconnected,  

   while shows a unbroken one means connected.   
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  2.9.1.1 Connect 

       A. USB cable connection 

a. Find USB ports on the right-side of machine and computer, plug in and connect.  

b. Open Flashprint software and turn on the printer. 

c. Click Print -> Connect Machine menu, then select USB in the Connection Mode option 

and select machine you want to connect in Select Machine option. If you can not find 

your machine, click Rescan button to scan your machine and select it. Finally click 

Connect button to connect to the printer. If you still can not find your machine after 

rescan, which means you haven’t installed the driver in the software. You have to install 

the driver manually, please refer to the Chapter 2.8.3.1. Normally, driver shall be 

installed automatically along with software.  

 

        B. WIFI connection 

            a.  Via wireless network   

            1. Switch on the printer, and make the WIFI available by clicking the menu Tools ->Set  

              up->WIFI->WIFI ON.  

            2. Open the wireless network connection in your computer, and choose .LPB wireless 

              network. It is the default network of the printer, and no password is needed if you  

              haven’t changed the settings. 

                           

            3. Open your browser and enter the IP address 10.10.100.254 in the Address Bar. Then 

              enter in admin as the account and password . (The above-mentioned IP address   

              /Account /Password are default when the setting haven’t been changed)                                                                                          
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            4. Click Work Mode, then choose AP+STA mode and save it. Please don’t click Reboot  

              button yet.          

                 

Note: If you choose the STA mode only, the printer may be unable to connect WIFI 

with the wrong STA setting. In this condition, it has the risk of being unable to connect 

the WIFI forever.  

            5. Click STA Setting, and then click Scan button and choose a commonly used network.  

              Type in password, save it, and then click Reboot to the printer. 
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             6. 5 seconds after the reboot, choose disconnect and try to connect WIFI again. Open 

               FlashPrint, click the menu Print->Connect to select WIFI connection, and then  

               enter the network IP address (same as the IP showed on the touchscreen) in the IP  

               port option. Finally click connect to complete it. After this, you do not need to  

               connect WIFI in the future if no WIFI setting is changed. If you want to change WIFI 

               setting, please try the same way. 

          b. Via wireless source set by the printer  

            1. Switch on the printer, and make the WIFI available by clicking the menu Tools ->Set 

              up->WIFI->WIFI ON”.  

            2. Open the wireless network connection in your computer, and choose .LPB wireless 

              network. It is the default network of the printer, and no password is needed if you  

              haven’t changed the settings. 

            3. menu Print -> Connect, and select Wi-Fi in the Connection Mode bar. Type in 

              10.10.100.254:8899 in the IP Address, Port bar, then click Connect button to  

              complete it. 

           Note: One printer could only have one connection. If printer is operating by another   

           process, connections should be switched off firstly and try to connect again. If AP mode  

           is chosen, the computer will be unable to go online by WIFI. 

2.9.1.2 Disconnect from the printer  

Click Print -> Disconnect menu on top of the software interface, the computer will disconnect 

from the 3D printer. 

2.9.2 Control Panel  

After connection between software and 3D printer is built, click Tools->Control Panel menu to open 

the control pane. Following operations are available in the control panel to control the printer. 
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A. Jog Controls 

a. Jog Mode:  

You could set the distance the extruder or the platform moves by a single jog click time.  

b. Direction Buttons:  

These six blue-arrow buttons are set to control the movements on X/Y/Z directions. Click the 

direction buttons of x-axes and y-axes to control the horizontal movements of the extruder. Click 

the direction buttons of z-axes to control the vertical movements of the platform. Click X- button to 

make the extruder move to the left; click X+ button to make the extruder move to the right. Click Y- 

button to make the extruder move forward; click Y+ button to make the extruder move backward. 

Click Z- button to make the platform move upward; click Z+ button to make the platform move 

downward.The distance of movement will be showed in the X/Y/Z value bar. 

c. Stop Button:  

  Click this button to terminate current movement. 

d. Coordinate frame:    

  It displays the coordinated positions of extruder and platform. 

e. Make current position zero button:  

Click this button to set the current position of the extruder and platform as the origin of 

coordinates.    

f. Center X/Y/Z button:  

 Click these buttons to return the extruder or platform to the origin of coordinates automatically.  

g. X/Y/Z Speed sliding bar:  

Set the moving speed of the extruder and platform by sliding the speed sliding bar. 

B. Limit Switch 
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In order to protect the 3D printer, there are three limit switches on X/Y/Z axes used to control the 

movement limited position. they have the following two statuses: 

a. Open Status:  

If the extruder or platform has not reached to the limit position of X/Y/Z direction, the switch won’t 

be triggered and its status is Open. 

b. Triggered Status:  

If the position of extruder or platform has reached to the maximum of X/Y/Z direction, the limit 

switch will be triggered and its status will be turn into Triggered. 

C. Fan Controls   

Click Open button to turn on the cooling the fan, while Close button to turn it off. 

D. Stepper Motor Control  

It is used to control the stepper motor. Click Open button to lock the stepper motor and users can not 

adjust the position of extruder and platform manually, while Close button to unlock it and users can 

do manual adjustment on extruder and platform.  

E. LED Color 

The printer has a built-in LED, Click LED Color button to change its color built in the printer. 

F. Extruder Setting   

In the interface of extruder setting, you could feed in or withdraw the filament from the left/right 

extruder. By changing the value of “Motor Speed (RPM)”, you could control the speed of feeding in 

and withdrawing filament. In addition, you could control the time of these actions through changing 

the value of “Extrude duration”. Generally, we suggest you set the extrude duration as 60s.  

Before feeding in or withdrawing the filament, the extruder should reach target temperature to melt 

the filament before you click Forward / Reverse button to start these operations. For ABS filament, 

target temperature of extruder is 220℃; for PLA filament, target temperature of extruder is 200℃.  

Click Stop button to stop feeding in or withdrawing filaments . 

G. Temperature Control  

Type in the target temperature in the left blank and click Apply button to heat the extruder or 

platform. The printer starts to heat the extruder or the platform, and you will see the actual 

temperature the extruder or platform has reached on the right and a temperature changing table  

with 3 different color curve line below. 

Note: The printer will heat platform firstly to reach target temperature and then heat extruders when 

both are needed to heat.  

2.9.3 Firmware Upgrade 

The software will check and download updates automatically when users open it, and remind users 

to upgrade to new version if available. Ways to install firmware as follows: 

 A. Disconnect the computer and printer, or Click Tools -> Update Firmware menu and select  

   Disconnect option, 

 B. Select your machine type and corresponding firmware in the popped up dialog and then click Ok 

to upgrade. If the machine is idle, it will start to upgrade to new firmware. 
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2.9.4 On Board Preferences  

When the printer has been connected, click Tools-> On Board Preferences menu to review the 

configuration of mother board including Machine Name, and Extruder count etc. When choosing 

extruder count as 2, Extruders Distance option is available. Users can modify the X/Y distance between 

the extruders as need.The X/Y distance refers to the distance of X or Y directions between the two 

extruders. 

 

2.9.5 Machine Information 

When the printer has been connected, click Tools->Machine Information menu to review the 

information about the machine, including MACHINE TYPE, MACHINE NAME, FIRMWARE VERSION, etc. 

2.9.6 Driver Installation 

A. Open the root directory of the software. (e.g. C:\Program Files\flashforge\FlashPrint) 

B. Open the driver folder which in the root directory and find the driver. There are two driver 

  installation packages, please install one of them according to your computer system. For 

  64bit edition, please install dpinst_amd64.exe file; while for 32bit edition, please install  

  dpinst_x86.exe file. 

2.10 Others  

2.10.1 Preferences 

Click File-> Preferences menu to select the interface language and etc. 
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A. Language  

      So far this software supports English, Japanese, Simplified Chinese and Traditional Chinese.  

B. Check for Update after Startup  

      Select Yes option to command the software auto-check updates after starting up it. The software 

      will remind you to update to new version when it is available after checking. 

2.10.2 Help Contents  

Click Help-> Help Contents menu to be directed to online user manual. 

2.10.3 Check for Updates  

  A. Automatic Update  

       Refer to 2.9.1 to set auto update. 

B. Manual Update   

       Click Help-> Check for Updates menu to check new version of software online. If a new version is  

       available, it will remind you to download and install the new one. Please refer to the Chapter 

       1.1~1.2 to install the software.  

2.10.4 Software Information 

Click Tools-> About FlashPrint menu to review information about the software, including software 

version and copyrights. 
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